3106 Posts in 506 Topics - by 54 Members - Latest Member: Terrordactyl

Author Topic: Site Bugginess  (Read 6675 times)

LordReaver

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1841
  • BLOOD FOR THE BLOOD GOD EMPEROR!
    • lordreaver.com
Site Bugginess
« on: November 17, 2012, 11:53:45 AM »
Site may look/act a little buggy as I change some user group permissions and such around.  Especially for guests and newly registered members.  The forum functionality should remain intact, so long as you have registered and made a hello post in the welcome board.  If you do encounter problems, please let me know so I can fix it!

« Last Edit: November 17, 2012, 12:16:53 PM by LordReaver »

StoneRhino

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1102
  • Minister of Blood: Living on a prayer...
Re: Site Bugginess
« Reply #1 on: November 18, 2012, 04:51:43 AM »
Clearly this sack of shit is a bot account... :D

LordReaver

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1841
  • BLOOD FOR THE BLOOD GOD EMPEROR!
    • lordreaver.com
Re: Site Bugginess
« Reply #2 on: November 18, 2012, 08:44:40 AM »
Yeah, and the irony of the bot posting in this topic.  :D

If people would just keep their anti-virus up to date, we wouldn't have to deal with this shit.

Apone

  • Guest
Re: Site Bugginess
« Reply #3 on: November 18, 2012, 10:53:18 AM »
These posts looked more like spam bots than those from an authorized user's virus infected computer.  Right now there are about ten suspicious accounts registered yesterday or today.  If security was recently loosened to allow registration upon simple email verification, then all you need to do is tighten it back up ... requiring a moderator to activate accounts for know humans.

If security settings don't fix it, then you are probably dealing with a CGI-PHP hack or (least likely) a SQL injection attack.

LordReaver

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1841
  • BLOOD FOR THE BLOOD GOD EMPEROR!
    • lordreaver.com
Re: Site Bugginess
« Reply #4 on: November 18, 2012, 01:42:10 PM »
'Security' wasn't changed, just who can see what.  There was just a surge in spam for whatever reason.  Probably due to someone posting a link on another site, which a spammer found and targeted.  I did up the security a little bit.  Will see if it needs more.

To explain the AV thing, spammers use infected computers to do their dirty work.  Which is why it's hard to block the spam.  I would love to add better security to the site, but it seems like SMF is a dieing forum software.  So there isn't a lot of new stuff being coded for it.   I would love to have at vBulletin (where it's at!), but I ain't payin' for it, that's for sure. It's like $250!

Apone

  • Guest
Re: Site Bugginess
« Reply #5 on: November 18, 2012, 03:31:54 PM »
I've pounded my head fighting this sort of thing for years.  The only thing that ever really worked was putting our servers behind a Cisco firewall. 

The bogus postings were from recently registered accounts and it looks like the guilty users were removed.  Sorting the member list by date still reveals several suspicious accounts that were registered over the past couple of days (tramadoful, Kartguaft, losewa, etc).  The next spam posts will likely come from one of them, but hopefully your tweaks will put a halt to the abuse.

It sucks that support is dwindling ... you've accumulated a ton of content that will be a pain to transfer.  I'm not familiar with SMF or vBulletin.  The Enjin gaming platform worked well for my old SWTOR guild, and it simultaneously supported several other games for the community (WoW, LoL, GW2, ...).  I just revisited www.enjin.com and found several snazzy new features were added.  It looks like they're rolling out specific support for PS2 and about 100 outfits have already begun using their service.  Prices range from $0 to $30/month.  No matter what you decide ... stay or go to a new service ... I'll pitch in to help with the costs.

LordReaver

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1841
  • BLOOD FOR THE BLOOD GOD EMPEROR!
    • lordreaver.com
Re: Site Bugginess
« Reply #6 on: November 18, 2012, 03:53:53 PM »
Yeah, I didn't remove the accounts without posts, because I couldn't tell at a glance if they were legit or not.  I figure no harm done if they aren't spamming.  They really can't do much beyond that right now anyway.  I'll probably go in and prune them within the next few days.

Apone

  • Guest
Re: Site Bugginess
« Reply #7 on: November 19, 2012, 01:01:38 PM »
I'm happy to assist screening/validating new accounts.  Just give me the word.

LordReaver

  • Administrator
  • Emperor's Champion
  • ********
  • Posts: 1841
  • BLOOD FOR THE BLOOD GOD EMPEROR!
    • lordreaver.com
Re: Site Bugginess
« Reply #8 on: November 19, 2012, 11:09:51 PM »
I may one day call upon your assistance, for now though I should have it under control.  I check in pretty much every day, so it's pretty hard for stuff to slip by me.  Though feel free to hit that report button when you feel it necessary, it sends both Stone and myself an email.